$re = '/\b(?:e\.g\.|i\.e\.)(*SKIP)(*F)|\pP+/';
$str = 'Blabla, i.e. e.g. blabla...';
$subst = " \0";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;