using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(?:e\.g\.|i\.e\.)(*SKIP)(*F)|\pP+";
string substitution = @" \0";
string input = @"Blabla, i.e. e.g. blabla...";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}