import Foundation
let pattern = #"\b(?:e\.g\.|i\.e\.)(*SKIP)(*F)|\pP+"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"Blabla, i.e. e.g. blabla..."#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #" \0"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)