#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "\b(?:e\.g\.|i\.e\.)(*SKIP)(*F)|\pP+"
Local $sString = "Blabla, i.e. e.g. blabla..."
Local $sSubst = " \0"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)