use strict;
my $str = 'Blabla, i.e. e.g. blabla...';
my $regex = qr/\b(?:e\.g\.|i\.e\.)(*SKIP)(*F)|\pP+/p;
my $subst = ' \\0';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";