package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\b(?:e\.g\.|i\.e\.)(*SKIP)(*F)|\pP+`)
var str = `Blabla, i.e. e.g. blabla...`
var substitution = " \0"
fmt.Println(re.ReplaceAllString(str, substitution))
}