# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/.*TFG\\/([^\\/]+)\\/([^\\/]+)\\/(.*)(\.py)/$1.$2.$3/;t' <<< "/foo/bar/spam/regex/TFG/pacman/search/file.py"