// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r".*TFG\/([^\/]+)\/([^\/]+)\/(.*)(\.py)").unwrap();
let string = "/foo/bar/spam/regex/TFG/pacman/search/file.py";
let substitution = "$1.$2.$3";
// result will be a String with the substituted value
let result = regex.replace(string, substitution);
println!("{}", result);
}