const regex = /.*TFG\/([^\/]+)\/([^\/]+)\/(.*)(\.py)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('.*TFG\\\/([^\\\/]+)\\\/([^\\\/]+)\\\/(.*)(\\.py)', '')
const str = `/foo/bar/spam/regex/TFG/pacman/search/file.py`;
const subst = `$1.$2.$3`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);