#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = ".*TFG\/([^\/]+)\/([^\/]+)\/(.*)(\.py)"
Local $sString = "/foo/bar/spam/regex/TFG/pacman/search/file.py"
Local $sSubst = "$1.$2.$3"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)