import re
regex = re.compile(r".*TFG\/([^\/]+)\/([^\/]+)\/(.*)(\.py)")
test_str = "/foo/bar/spam/regex/TFG/pacman/search/file.py"
subst = "$1.$2.$3"
result = regex.sub(subst, test_str, count=1)
if result:
print(result)