re = /.*TFG\/([^\/]+)\/([^\/]+)\/(.*)(\.py)/
str = '/foo/bar/spam/regex/TFG/pacman/search/file.py'
subst = '$1.$2.$3'
result = str.sub(re, subst)
# Print the result of the substitution
puts result