# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\bST(?:REET)?+\B/$0 /gm;t' <<< "703 6TH STREET SOUTHTEXAS CITY TX 77590
1201 WEST FRONT STREETCHESTER PA 19013-3496
1201 WEST FRONT STCHESTER PA 19013-3496
"