import re
regex = re.compile(r"\bST(?:REET)?+\B", flags=re.MULTILINE)
test_str = ("703 6TH STREET SOUTHTEXAS CITY TX 77590\n"
"1201 WEST FRONT STREETCHESTER PA 19013-3496\n"
"1201 WEST FRONT STCHESTER PA 19013-3496\n")
subst = "$0 "
result = regex.sub(subst, test_str)
if result:
print(result)