using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\bST(?:REET)?+\B";
string substitution = @"$0 ";
string input = @"703 6TH STREET SOUTHTEXAS CITY TX 77590
1201 WEST FRONT STREETCHESTER PA 19013-3496
1201 WEST FRONT STCHESTER PA 19013-3496
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}