#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\bST(?:REET)?+\B"
Local $sString = "703 6TH STREET SOUTHTEXAS CITY TX 77590" & @CRLF & _
"1201 WEST FRONT STREETCHESTER PA 19013-3496" & @CRLF & _
"1201 WEST FRONT STCHESTER PA 19013-3496" & @CRLF & _
""
Local $sSubst = "$0 "
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)