const regex = /\bST(?:REET)?+\B/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\bST(?:REET)?+\\B', 'gm')
const str = `703 6TH STREET SOUTHTEXAS CITY TX 77590
1201 WEST FRONT STREETCHESTER PA 19013-3496
1201 WEST FRONT STCHESTER PA 19013-3496
`;
const subst = `$0 `;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);