re = /\bST(?:REET)?+\B/m
str = '703 6TH STREET SOUTHTEXAS CITY TX 77590
1201 WEST FRONT STREETCHESTER PA 19013-3496
1201 WEST FRONT STCHESTER PA 19013-3496
'
subst = '$0 '
result = str.gsub(re, subst)
# Print the result of the substitution
puts result