use strict;
my $str = '703 6TH STREET SOUTHTEXAS CITY TX 77590
1201 WEST FRONT STREETCHESTER PA 19013-3496
1201 WEST FRONT STCHESTER PA 19013-3496
';
my $regex = qr/\bST(?:REET)?+\B/mp;
my $subst = '$0 ';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";