#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(\d*)?\s*?([a-zA-Z]+)\s*(\d+)(?::(\d+))?(\s*-\s*(\d+)(?:\s*([a-z]+)\s*(\d+))?(?::(\d+))?)?"
Local $sString = "John 14:16" & @CRLF & _
"1John 14:16" & @CRLF & _
"1 John 14:16" & @CRLF & _
"john 14:16" & @CRLF & _
"1john 14:16" & @CRLF & _
"1 john 14:16" & @CRLF & _
"Jo 14:16" & @CRLF & _
"1Jo 14:16" & @CRLF & _
"1 Jo 14:16" & @CRLF & _
"jo 14:16" & @CRLF & _
"1jo 14:16" & @CRLF & _
"1 jo 14:16" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")