import re
regex = re.compile(r"(\d*)?\s*?([a-zA-Z]+)\s*(\d+)(?::(\d+))?(\s*-\s*(\d+)(?:\s*([a-z]+)\s*(\d+))?(?::(\d+))?)?", flags=re.MULTILINE)
test_str = ("John 14:16\n"
"1John 14:16\n"
"1 John 14:16\n"
"john 14:16\n"
"1john 14:16\n"
"1 john 14:16\n"
"Jo 14:16\n"
"1Jo 14:16\n"
"1 Jo 14:16\n"
"jo 14:16\n"
"1jo 14:16\n"
"1 jo 14:16\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")