import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\d*)?\\s*?([a-zA-Z]+)\\s*(\\d+)(?::(\\d+))?(\\s*-\\s*(\\d+)(?:\\s*([a-z]+)\\s*(\\d+))?(?::(\\d+))?)?";
final String string = "John 14:16\n"
+ "1John 14:16\n"
+ "1 John 14:16\n"
+ "john 14:16\n"
+ "1john 14:16\n"
+ "1 john 14:16\n"
+ "Jo 14:16\n"
+ "1Jo 14:16\n"
+ "1 Jo 14:16\n"
+ "jo 14:16\n"
+ "1jo 14:16\n"
+ "1 jo 14:16\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}