// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(\d*)?\s*?([a-zA-Z]+)\s*(\d+)(?::(\d+))?(\s*-\s*(\d+)(?:\s*([a-z]+)\s*(\d+))?(?::(\d+))?)?").unwrap();
let string = "John 14:16
1John 14:16
1 John 14:16
john 14:16
1john 14:16
1 john 14:16
Jo 14:16
1Jo 14:16
1 Jo 14:16
jo 14:16
1jo 14:16
1 jo 14:16
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}