package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\d*)?\s*?([a-zA-Z]+)\s*(\d+)(?::(\d+))?(\s*-\s*(\d+)(?:\s*([a-z]+)\s*(\d+))?(?::(\d+))?)?`)
var str = `John 14:16
1John 14:16
1 John 14:16
john 14:16
1john 14:16
1 john 14:16
Jo 14:16
1Jo 14:16
1 Jo 14:16
jo 14:16
1jo 14:16
1 jo 14:16
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}