const regex = /(\d*)?\s*?([a-zA-Z]+)\s*(\d+)(?::(\d+))?(\s*-\s*(\d+)(?:\s*([a-z]+)\s*(\d+))?(?::(\d+))?)?/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d*)?\\s*?([a-zA-Z]+)\\s*(\\d+)(?::(\\d+))?(\\s*-\\s*(\\d+)(?:\\s*([a-z]+)\\s*(\\d+))?(?::(\\d+))?)?', 'gm')
const str = `John 14:16
1John 14:16
1 John 14:16
john 14:16
1john 14:16
1 john 14:16
Jo 14:16
1Jo 14:16
1 Jo 14:16
jo 14:16
1jo 14:16
1 jo 14:16
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}