import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "exec \\w+ (?:.*?'(?<quotedWord>\\w+)')+";
final String string = "exec GetNextSequence 'abc', @brokerId out, 'fds'\n"
+ "insert into [ttt](id, code, description, startDate, endDate)\n"
+ "values (@bid, @code, @code, getdate(), '099999')\n"
+ "....";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}