import re
regex = re.compile(r"exec \w+ (?:.*?'(?<quotedWord>\w+)')+")
test_str = ("exec GetNextSequence 'abc', @brokerId out, 'fds'\n"
"insert into [ttt](id, code, description, startDate, endDate)\n"
"values (@bid, @code, @code, getdate(), '099999')\n"
"....")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")