$re = '/exec \w+ (?:.*?\'(?<quotedWord>\w+)\')+/';
$str = 'exec GetNextSequence \'abc\', @brokerId out, \'fds\'
insert into [ttt](id, code, description, startDate, endDate)
values (@bid, @code, @code, getdate(), \'099999\')
....';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);