const regex = /exec \w+ (?:.*?'(?<quotedWord>\w+)')+/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('exec \\w+ (?:.*?\'(?<quotedWord>\\w+)\')+', '')
const str = `exec GetNextSequence 'abc', @brokerId out, 'fds'
insert into [ttt](id, code, description, startDate, endDate)
values (@bid, @code, @code, getdate(), '099999')
....`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}