re = /exec \w+ (?:.*?'(?<quotedWord>\w+)')+/
str = 'exec GetNextSequence \'abc\', @brokerId out, \'fds\'
insert into [ttt](id, code, description, startDate, endDate)
values (@bid, @code, @code, getdate(), \'099999\')
....'
# Print the match result
str.match(re) do |match|
puts match.to_s
end