#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\d{2}(?:-\d{2})?(?:,\s*\d{2}(?:-\d{2})?)*$"
Local $sString = "01,02,03,04" & @CRLF & _
"1002003" & @CRLF & _
"01,02,03" & @CRLF & _
"A, B, C" & @CRLF & _
"s01, s02, s02" & @CRLF & _
"E2702-2703,E2702-2703" & @CRLF & _
"03,05,06" & @CRLF & _
"05-08,09,10-12, 05-08"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")