import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\d{2}(?:-\\d{2})?(?:,\\s*\\d{2}(?:-\\d{2})?)*$";
final String string = "01,02,03,04\n"
+ "1002003\n"
+ "01,02,03\n"
+ "A, B, C\n"
+ "s01, s02, s02\n"
+ "E2702-2703,E2702-2703\n"
+ "03,05,06\n"
+ "05-08,09,10-12, 05-08";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}