package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\d{2}(?:-\d{2})?(?:,\s*\d{2}(?:-\d{2})?)*$`)
var str = `01,02,03,04
1002003
01,02,03
A, B, C
s01, s02, s02
E2702-2703,E2702-2703
03,05,06
05-08,09,10-12, 05-08`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}