import re
regex = re.compile(r"^\d{2}(?:-\d{2})?(?:,\s*\d{2}(?:-\d{2})?)*$", flags=re.MULTILINE)
test_str = ("01,02,03,04\n"
"1002003\n"
"01,02,03\n"
"A, B, C\n"
"s01, s02, s02\n"
"E2702-2703,E2702-2703\n"
"03,05,06\n"
"05-08,09,10-12, 05-08")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")