$re = '/^\d{2}(?:-\d{2})?(?:,\s*\d{2}(?:-\d{2})?)*$/m';
$str = '01,02,03,04
1002003
01,02,03
A, B, C
s01, s02, s02
E2702-2703,E2702-2703
03,05,06
05-08,09,10-12, 05-08';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);