// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^\d{2}(?:-\d{2})?(?:,\s*\d{2}(?:-\d{2})?)*$").unwrap();
let string = "01,02,03,04
1002003
01,02,03
A, B, C
s01, s02, s02
E2702-2703,E2702-2703
03,05,06
05-08,09,10-12, 05-08";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}