const regex = new RegExp('^\\d{2}(?:-\\d{2})?(?:,\\s*\\d{2}(?:-\\d{2})?)*$', 'gm')
const str = `01,02,03,04
1002003
01,02,03
A, B, C
s01, s02, s02
E2702-2703,E2702-2703
03,05,06
05-08,09,10-12, 05-08`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}