# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/[^e]/?/gi;t' <<< "This is my very long regex test string - I'm testing it! :)"