import re
regex = re.compile(r"[^e]", flags=re.IGNORECASE)
test_str = "This is my very long regex test string - I'm testing it! :)"
subst = "?"
result = regex.sub(subst, test_str)
if result:
print(result)