const regex = /[^e]/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[^e]', 'gi')
const str = `This is my very long regex test string - I'm testing it! :)`;
const subst = `?`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);