package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)[^e]`)
var str = `This is my very long regex test string - I'm testing it! :)`
var substitution = "?"
fmt.Println(re.ReplaceAllString(str, substitution))
}