# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<=(?:sin|cos|tan)\([^)]*)x/x°/gm;t' <<< "f(x+1)+g(x)+2x-sin(x+1)+2cos(3x)"