re = /(?<=(?:sin|cos|tan)\([^)]*)x/m
str = 'f(x+1)+g(x)+2x-sin(x+1)+2cos(3x)'
subst = 'x°'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result