const regex = /(?<=(?:sin|cos|tan)\([^)]*)x/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=(?:sin|cos|tan)\\([^)]*)x', 'gm')
const str = `f(x+1)+g(x)+2x-sin(x+1)+2cos(3x)`;
const subst = `x°`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);