$re = '/(?<=(?:sin|cos|tan)\([^)]*)x/m';
$str = 'f(x+1)+g(x)+2x-sin(x+1)+2cos(3x)';
$subst = "x°";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;