use strict;
my $str = 'f(x+1)+g(x)+2x-sin(x+1)+2cos(3x)';
my $regex = qr/(?<=(?:sin|cos|tan)\([^)]*)x/mp;
my $subst = 'x°';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";