using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=(?:sin|cos|tan)\([^)]*)x";
string substitution = @"x°";
string input = @"f(x+1)+g(x)+2x-sin(x+1)+2cos(3x)";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}