#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?<=(?:sin|cos|tan)\([^)]*)x"
Local $sString = "f(x+1)+g(x)+2x-sin(x+1)+2cos(3x)"
Local $sSubst = "x°"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)