# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<!\.\d\d)\n/;\n/g;t' <<< "enter This line ends with text
this line ends with a number: 55
this ends with 2-decimal number: 5.00
here's 22.22, not at the end of the line
"