# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<!\.\d\d)\n"
test_str = ("enter This line ends with text\n"
"this line ends with a number: 55\n"
"this ends with 2-decimal number: 5.00\n"
"here's 22.22, not at the end of the line\n")
subst = ";\\n"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.